How to fix Authentication is required error in Google Play Store on Android devices

Last week, while opening Google Play Store on my phone, I got an error message: Authentication is required. You need to sign into your Google Account. RetryI wasn’t sure why this error popped up my two Gmail addresses are already added and synced in the Google accounts settings of my phone. On the Google help forums, some said it occurs if you have an outdated Google Play Store app.

However, even after installing the latest version, the Authentication required error would come up whenever I accessed Google Play Store to update or download apps. I could of course download/update apps by logging into the Google Play website on my laptop browser, but that is very convenient. Fortunately, I have found some effective methods to fix Authentication is required error in Google Play Store:

Google Play Store Authentication required error fix 

Google play "authentication is required" error message screenshot

First method: Clear Google Play Store Data

This is the first method you should try for any Google Play Store related errors. It is swift and effective in fixing various Android market error codes.
  1. Go to System Settings >> Apps >> App
  2. Scroll down and select “Google Play Store” from the list of apps
  3. Tap “Clear Data”
  4. Now go back and open Google Play Store

Additionally, you can also clear data for “Google Service Framework”.
You can tap the menu icon on the top left to see that the Google Play app is synced the current Gmail account. Proceed to download apps or update your installed apps.

Method 2: Remove and add back Gmail account in device settings

  • Go to settings >> Accounts >> Tap on Google >> Select your primary Gmail account
  • Tap menu or the dotted button on the top right >> Tap “Remove account” and confirm
Now open Google Play Store and you will be asked to login your Gmail account
Follow instructions and add your Google account. The error should now be solved.

Method 3: Uninstall Google Play Store update

Please note that uninstalling Google Play Store update may not be possible on devices running Android 5. Lollipop, Android 6 MarshMallow or the latest Android 7 Nougat operating system. Still, you can try these steps and see if it works:
  • Go to Settings >> Apps >> All
  • (On LG devices you navigate to settings >> General >> App. Also tap on top right menu icon to enable “show system apps”)
  • From the list of apps, tap on “Google Play Store” >> Select “Uninstall updates”

This will revert Google Play Store app to its original unupdated version. The old version might not have the same bug that is causing issues in the latest Google Play app. Now go ahead and open the Google Play Store app and see if you still get the “Authentication required” error.

Lastly, I see that some other blogs have recommended “factory reset” as a method. But I don’t think you have to go through that route,


I fix errors or at least try to...

    Blogger Comment
    Facebook Comment